FastReport4.x 在 XE XE2 下編譯失敗的問題

如果是買FastReport正式版的使用者,可能會遇到FastReport 4.x的Source編譯失敗的情況

其實是因為XE2它為了與FireMonkey相容的關係

所以會把uses的位置做了一些修改

比方說:
uses Comobj;

修改成
uses system.win.ComObj;

所以在Source下可以稍微做個小修改,可以向下相容舊的FastReport版本

{$IFDEF VER230} system.win.ComObj, {$ELSE} ComObj, {$ENDIF}

其它沒講到的unit可以參考XE2的Help再修改。

參考來源:
Delphi XE2 cannot find ComObj.dcu where did it go?
What is the compiler version for Delphi 2010?












你,上了嗎?
引用來源
  

留言

這個網誌中的熱門文章

對於 Delphi 10.1 Berlin 推出的看法

Delphi ORM Generator